Sunday, June 14, 2009


My dealer told me the car is running and should be ready to go soon, this is a bittersweet moment. I get my car back which is great, just too bad it’s going to be hard to enjoy it because of how Audi treated me.
Throughout this process my dealer provided me with a loaner car, the first was a 3.2 litre 2009 A4 and the second a 2.0 litre 2009 A4. The second car the 2.0 hopefully is not a representation of Audi’s build quality, the Dynamic suspension did not work and I was told this is typical on these cars until dealers apply a software update. The second issue I had was the Air Conditioning did not work on the car, it’s brand new! The car only blows in outside air and boy does that black interior get hot. On a positive note the new electronics package on the cars is very nice; I like the park assist and the blind spot indicator on the mirrors. The new mirrors are also larger which gives better visibility on the side. My favourite is the keyless entry and start button although the second loaner car required me to pull the handle twice prior to unlocking while the 3.2 unlocked as soon as I was close.
Anyways this upcoming week may be very busy since the car will have to go back to the stereo store to have the Nav and related equipment all re-installed. The insurance company is applying a 10% depreciation to all the equipment :(.

Tuesday, June 9, 2009


Garbage - Fitting
Originally uploaded by homeychan
This picture seems to sum up my car and my opinion of Audi Canada - Garbage.

I have not posted a lot lately, I was out of town. I am back but will be gone again this weekend.
I have been told by the dealer that the short block has arrived and the valve stem seals have been replaced in the heads. Looks like there might have been some leakage through the valve stems and now it has been fixed I hope. My insurance company is working with me to get my stereo replaced and hopefully that can all be co-ordinated so when I get the car back it is all fixed. My dealer rules!
Audi Canada is a giant pain in the butt and sadly I really despise those people. I can’t understand what I am missing to explain why they have treated me the way they have. You buy a luxury car it breaks because of a manufacturers defect, the car goes in for service several times while within the warranty period and they deny warranty. They are always vague and provide a reason that suits the situation. Bottom line Audi sucks!

Tuesday, June 2, 2009

Nav Unit?

Missing Stereo Big
Originally uploaded by homeychan
This is whats left of my Nav unit while my dealer and me have been fighting with Audi to get warranty. My car was broken into and all of my stereo equipment stolen.